View Single Post
Old 08-13-2016, 02:27 PM   #3
Flogger
Registered User
 
Join Date: Jul 2016
Posts: 4
Re: Spearfishing with Aquascooter as600

Quote:
Originally Posted by e.m.p! View Post
Hi there,

Sounds very much like a carburetor issue. Best thing is to clean it and get some high quality marine grade 2 stroke oil to get it running.
For your second issue – check the seal on the exhaust. The suction cup (and spring) must be replaced regularly (instructions say once a year, but I guess this depends on use) if it's flat it may be that water gets up the exhaust with increasing water pressure. Also, check the blue tube going from tank into the air chamber. It needs to be dry and clear for regulating the pressure in the fuel tank. Another thing could be to check how much water gets in through the front lid, you may accidentally flood it?
There's an italian spearo forum (pescasubapnea?) that have a whole crew dedicated to aquascooter issues and great concepts for tuning. I haven't had any issues with mine, but I bought it from new, so fingers crossed I won't have any problems soon. Good luck
Thanks for the reply. As you say, its like possibly exhaust valf and carburetor problem. Try to order new valve but its somehow difficult to get spare parts from Italy. Thinking dismantle the carburetor but the valve in the first line. I am sure there is no water in the air chamber. Hoses and seals looking good. Maybe gas hose needs to be changed. Also, I can't find anything helpful in italian spearfishing forums about aquascooter. English translation of italian forums inconceivable. I will also attach some photos of aquascooter, while i work on it. Thanks again.

LG-D802 cihazımdan Tapatalk kullanılarak gönderildi
Flogger is offline   Reply With Quote